Rails

Nginx+mongrel+rails+ubuntu部署应用

我知道现在后端服务器有很多,但是为了与windows发布相对应,这里的后端选择mongrel。。。 思路:1.mongrel以守护进程方式运行rails          2.安装配置Nginx    一、mongrel以守护进程方式运行rails

2015-07-13 11:10:09

在windows平台下使用nginx和thin作为rails的服务器

由于mongrel已经年久失修、不支持最新的1.9.2版本了、所以现在使用thin作为rails服务器、再加上nginx作反向代理、 首先安装thin吧、在windows平台下、需要先安装eventmachine、否则不能安装thin服务器 gem install eventmachine --pregem install thin 安装完成后

2015-07-13 11:07:45

ruby1.9.2+rails3+nginx+passenger+postgresql

服务器部署之 ruby1.9.2+rails3+nginx+passenger+postgresql 2 次投票 jerry 分享于 3 个月 前, 5 条回复, 569 次浏览 Share | 服务器系统: ubuntu server 10.04 64bit 案例服务器: Linode VPS 512系列. 服务器系统: ubuntu server

2015-07-13 11:04:39

Nginx + unicorn 运行多个Rails应用程序

PS:第一次写的很详细,可惜发布失败,然后全没了,这是第二次,表示只贴代码,剩下的自己领悟好了,这就是所谓的一鼓作气再而衰吧,希望没有第三次。 版本:   ruby 2.1.0   rails 4.0.2   nginx 1.5.8 mainline version   unicorn 4.7.0  /usr/local/ng

2015-07-13 11:02:14

Nginx+Mongrel+Rails 3.0+Windows部署发布

    偶知道大家都不提倡在windows下进行rails的开发,更不提倡在windows下进行rails的部署。。。。 但是有个项目确实存在这个需求,既然平台因素无法忽略,就只好逆天而行了…       思路:Nginx实现前端(有人说nginx在windows下性能

2015-07-13 11:01:32

安装RVM,Ruby,Rails;布暑 passenger + nginx

    本文仅为作者本人经验之谈,可供参考。安装过程中,有问题可以加qq1403126229,我尽量回答(有空,并且我懂的话)        本文可能不断更新,转载请注明出处www.cnblogs.com/kelby。谢谢。 ====================

2015-07-13 11:01:30

centos+nginx+ruby(and rails)+mongrel+php+mysql centos安装php常见错误

安装gcc yum -y install gcc 安装g++ yum install gcc-c++ 安装libxml2 /* wget http://mirror.centos.org/centos-5/5/os/i386/CentOS/libxml2-2.6.26-2.1.2.8.i386.rpm rpm

2015-07-13 10:56:09

Hello Lavarel(最接近rails的php mvc web框架)

Laravel是一套简洁、优雅的PHP Web开发框架(PHP Web Framework)。它可以让你从面条一样杂乱的代码中解脱出来;它可以帮你构建一个完美的网络APP,而且每行代码都可以简洁、富于表达力。 官网地址 http://laravel.com/ 中文站地址 http://www.golaravel.com/ 代码托管地

2015-07-10 14:21:43

Passenger/Nginx/Ubuntu/MySQL详尽部署Rails 4.2.1/Ruby2.2.2

关于Rails部署在Ubuntu下,网上有很多相应的方法。刚开始学习时,部署成了最大的难题。相对于Java的部署,要更复杂些,更重要Rails对Windows的支持不好,所以建议使用Linux进行部署。 我的VPS为Linode的Ubuntu14.04 LTS,总结一下网上所学到的知识和自己的部署过程,以方便初学者可以更容易的部署环境。因为我刚开始部署时,

2015-07-07 16:15:37

ubuntu 14.04中安装 ruby on rails 环境(填坑版) 呕血推荐

环境:在win7 上Vmware虚拟机环境中安装的ubuntu 14.04开发相关:ruby 2.2.0rails 4.2.0sublime text 3   本文说明:所有的命令均在$ 之后,若$前边带有信息,只是为了方便你理解和与自己对照。 安装过程中由于这样那样的原因,产生许多坑,所谓坑是对初学者来说,大牛们飘过吧。 步骤1、从官网下

2015-07-07 16:15:18

rails笔记: view

view view分为 builder模式和rhtml模式 builder模式例子如下,rails自带xml.div(:class => \"productlist\") do xml.timestamp(Time.now) @products.each do |product| xml.pro

2015-07-07 15:36:15

[ROR] ruby on rails 入门知识

viewview分为 builder模式和rhtml模式builder模式例子如下,rails自带xml.div(:class => \"productlist\") doxml.timestamp(Time.now)@products.each do |product|xml.product doxml.productname(product

2015-07-07 15:36:13

rails常用gem

  一,开发模式下   1,better_errors   使用全新的页面替换 Rails 默认的错误页面,显示更多的上下文信息,例如源码 和变量的值;配合binding_of_caller可以执行代码查看变量的值 2,meta_request 是 Rails Panel的支持gem包, Rails Panel是chrome浏

2015-07-07 15:35:37

Rails中的MIME类型

layouttitledatecommentscategories post rails的中的MIME类型 2014-09-08 21:40 true ruby Rails开发中经常使用不同的请求格式来处理不同的响应,最常见的是同一个action对html/text和json格式的响应不同的数据。 那么, Rail

2015-07-07 15:35:35

Agile Web Development with Rails 翻译(五十)

Agile Web Development with Rails 翻译(五十) 17.4 Helpers 这有两个主要原因。首先,在你的应用程序“视图”端放置大量的代码,很容易会让你降低要求并开始添加应用级别的功能给“模板”内的代码。这是个糟糕的风格;你希望放置应用程序代码在“控制器”和“模型”层中,以便在任何地方都可以使用它们。在你给应用程序

2015-07-07 15:33:54

安装配置Jruby on Rails

1.下载并安装  jruby 1.6.8 (ruby-1.8.7-p357) (2012-09-18 1772b40) 2.安装rake    rack (1.4.5, 1.0.1) gem install rake 3.安装rails      &n

2015-07-07 15:33:06

Rails常用插件

测试驱动 rspec-rails:BDD测试框架            初始化:rails generate rspec:install capybara:模拟浏览器器行为 factory_girl_rails:生成数据 database_cleaner:清除数据库数据 simplec

2015-07-07 15:33:03

ruby on rails在fedora18上install

ruby on rails 在fedora18下的安装 天朝的网络原因,安装不是很顺畅,所以把过程记录下备用 前面下载rubygem什么的都比较快,新建一个project的时候会出问题 gem new my_project  会在bundle_install处卡很久,然后提示说某某东西没装,让装一下。。 大体上参考了两篇文章: &nbs

2015-07-07 15:32:42

The Six Types of Rails Association

翻译整理自:http://guides.rubyonrails.org/v3.2.13/association_basics.html 想吐槽一句,http://guides.ruby-china.org/  翻译地太慢了!!! csdn 复制过来格式都有误啊,改格式改了好几遍了。烦心。。。。 什么时候能支持markdown呢-。-

2015-07-07 15:31:32

rails中常用的插件

Authlogic: authlogic作为一款强大的登录验证插件,受到不少人的喜欢,使用非常简单,支持rails3,可以参考github上的api: http://github.com/binarylogic/authlogic 搜索 will_paginate: will_paginate是用到最到的一款插件,支持Rails3,

2015-07-07 15:30:43