Mac OS

Mysql/MAMP + Django1.8.2(Win7 64bit/Mac OS X)环境搭建

Win 7 64bit + Mysql5.6.25: 1. 使用mysql connector/Python 2.1.2: oracle官方的mysql connector/Python现在暂时不支持Django1.8,所以拿Django1.7.8测试了下,发现mysql connector/Python自从2.X版本后其返回数据都是bytearr

2015-07-29 11:33:18

Linux/Mac OS X安装新版本python & linux 下 python django mod_python安装

操作系统:Linux Cent OS 5 / Max OS X 10.6 snow leopard 安装版本:Python2.6.4   Mac OS X 10.2 及其后续版本已经预装了Python,10.6 snow leopard 下的python版本已经内置了2.3,2.4,2.5 Cent OS 5也有内置Python 系统内置

2015-07-29 11:33:17

Mac os X 配置 django + uWSGI + nginx 简单构建过程分享

python的安装就不多说了 一.Django的安装,从https://www.djangoproject.com/download/,Django官网参考下载方式 我用的方法是: First, download Django-1.6.2.tar.gz (checksums). Then: tar xzvf Djang

2015-07-29 11:30:40

MAC OS X 中配置Apache+MySQL+PHP及rewrite功能

2015-07-21 10:23:42

MAC OSX10.10上搭建Apache,PHP,MySQL5.6.22,phpMyAdmin开发环境

用惯了在Windows上一个appserv或phpStudy压缩包搞定,要在MAC上捣腾一个PHP开发环境还不大习惯。但自己亲自配一下环境还是有所收获的。众所周知OSX上自带了apache和php,所以这两个搞起来还比较顺利。装MySQL的最新版5.6.22版颇费周折,本文详细记录之。 apache的配置 apache已经自带了,只需如下三个命令就可

2015-07-21 10:23:41

在 Mac OS X 10.5 (Leopard) 上安装适用于 Oracle 的 PHP 5.2

如果您曾经参加过 PHP 大会,那么您可能会因为看到的都是 Mac 笔记本电脑而认为 Apple 是赞助商。很多携带 Mac 的 PHP 开发人员将 Linux 作为虚拟机运行,而越来越多的 PHP 开发人员本地工作在 Mac 上。认识到这一事实,Oracle 大幅简化了 Mac 上的 PHP/Oracle 应用程序开发。通过本指南,您将了解到设置 Mac

2015-07-21 10:23:11

Mac OS Ruby安装 使用RVM

访问http://www.ruby-lang.org/en/downloads/ 使用第三方工具安装ruby,经过了解,在mac下可以使用macports和rvm安装ruby。 经过实际操作觉得rvm方式更好一些。 现在就开始使用rvm安装ruby 1.打开终端,必须先安装git. Java代码 &

2015-07-13 11:31:29

Mac OS X上安装 Ruby运行环境

如何在Mac OS X上安装 Ruby运行环境     对于新入门的开发者,如何安装 Ruby和Ruby Gems 的运行环境可能会是个问题,本页主要介绍如何用一条靠谱的路子快速安装 Ruby 开发环境。此安装方法同样适用于产品环境! 系统需求 首先确定操作系统环境,不建议在 Windows 上面搞,所以你需要用: Mac O

2015-07-13 11:30:55

Mac OS X 10.4.8 下安装Ruby On Rails

原来在windows下都用 Ruby One-Click安装Ruby,然后利用Ruby-gem,安装Rails,ZenTest等等 这次千辛万苦换到Mac,还是免不了一顿麻烦 首先,推荐一篇文献 http://wiki.rubyonrails.org/rails/pages/Installation 其实一步步来一点问题都没有,但是...


在Mac OS X Lion上安装Ruby On Rails

主要参考 http://ruby-china.org/wiki/install_ruby_guide Lion已经自带Ruby,在命令行中输入 $ ruby -v 可以得到 ruby 1.8.7 (2010-01-10 patchlevel 249) [universal-darwin11.0] 这个版本能用,但是会引起Rails 3崩溃。所以至少要把rub


如何在Mac OS X上安装 Ruby运行环境

  对于新入门的开发者,如何安装 Ruby和Ruby Gems 的运行环境可能会是个问题,本页主要介绍如何用一条靠谱的路子快速安装 Ruby 开发环境。此安装方法同样适用于产品环境! 系统需求 首先确定操作系统环境,不建议在 Windows 上面搞,所以你需要用: Mac OS X  任意 Linux 发行版本(Ubuntu,CentO

2015-07-13 11:20:30

Mac OS X下让ruby支持tcl/tk

    我记得在老早在OS X10.8下使用ruby1.9.x的时候只要到下载安装ActiveTcl8.5,没怎么配置就运行tk好好的。但是近日想重新执行下tk代码,发现在require \'tk\'的时候就报错鸟!现在用的是ruby2.1.3版本。上网搜了一下,1.9.x之后的版本默认不再将tcl/tk支持编译到ruby里面,so如果你

2015-07-13 11:15:12

在Mac OS X上建立Ruby on Rails开发环境

这篇文章是我看了阿修写“在Mac OS X上建立Ruby on Rails开发环境”,照着他的步骤作了一遍之后,整理而来的。内容基本上一致,添加了一些图而已。如果你希望看到原版的内容,请看这里阿修的部落格要在Mac上安装Ruby on Rails,首先必须要安装MAMP,这是一个打包了Apache,MySQL,PHP的套件。安装的过程


Mac os x下配置nginx + php

一直都没使用过PHP的,最近leader推荐使用他在维护的一个移动端的js框架,在本地合并压缩使用的是php环境处理的,so,只能是搭一个PHP的环境了。一直使用的本地代理服务器都是nginx,虽然PHP和Apache挺般配的,Mac上也自带Apache,但是本地的静态服务一直都是用的nginx,不想在换到Apache上,所以就自己将nginx和PHP配了下

2015-07-13 11:11:25

MAC OS X 折腾 macports nginx php-fpm 环境资料

http://www.netgli.com/157.html http://www.youth2009.org/uninstall-macports.html http://interfacelab.com/nginx-php-fpm-apc-awesome/ http://www.softwareprojects.com/resources/prog

2015-07-13 11:10:05

在Mac OS X 10.9上安装nginx

1. 安装PCRE   Download latest PCRE. After download go to download directory from terminal.   $ cd ~/Download $ tar xvzf pcre-8.34.tar.gz  $ cd pcre-8.34 $ s

2015-07-13 11:08:21

Mac OS Lion 下编译安装Nginx 1.0.12 + PHP 5.3.10 + Mysql 5.5.18 + Xdebug + PHPUnit

    在mac下编译安装了最新版本namp的环境, 记录一下安装过程, 其实总体和linux下没有太多区别,另外port是个好东西。  mysql编译安装:  1. 建立mysql数据存储目录, 权限设置为mac os默认存在的_mysql权限: mkdir -p /var/mysql/data/chown

2015-07-13 11:04:29

mac os maverick下安装nginx+php-fpm via homebrew

自己虽然平时爱折腾,却很少有记下来的习惯,除非碰到特别多问题的部署才会有冲动。今天看同事折腾git,在旁边看着他mac上的evernote满满的记了好几篇,全是技术相关的记录,忽然很感慨。过去解决了很多碎片化的问题,都没有系统地记下来,虽然今后也不能保证,但起码会决心挤出时间来写点东西(现在私人时间多了   安装nginx: mac上好用的软

2015-07-13 11:03:59

Eclipse/CDT(Linux/Mac osx) 极速配置

一、版本:   Eclipse: 3.2.0 1、Window->Perferences->C/C++:     (3) Indexer 有Bug,默认没激活。如果只读,不编辑代码,可以激活它。写代码的话,千万别激活它,否则,嘿嘿嘿嘿,要不

2015-07-13 10:43:51

安装Oracle JDK 7.0与8.0 for Mac OS X后Eclipse启动报错的解决之道

启动 Eclipse 时,直接报错The JVM shared library "/Library/Java/JavaVirtualMachines/jdk1.8.0_25.jdk/Contents/Home/bin/../jre/lib/server/libjvm.dylib"does not c

2015-07-13 10:43:16