macosx zsh下安装rvm和ruby

作者: 圆旭
发布时间:2015-08-10 15:42:22

1)curl -L get.rvm.io | bash -s stable

2)把下面一行加到~/.zshrc中:

[[ -s "$HOME/.rvm/scripts/rvm" ]] && . "$HOME/.rvm/scripts/rvm"

3)source ~/.zshrc

4)修改rvm的ruby安装源到国内的淘宝镜像服务器,可提高安装速度。

sed -i -e 's/ftp\.ruby-lang\.org\/pub\/ruby/ruby\.taobao\.org\/mirrors\/ruby/g' ~/.rvm/config/db

5)Ruby 的安装与切换

列出已知的 Ruby 版本

rvm list known

安装一个 Ruby 版本

rvm install 2.2.0

这里安装了最新的 2.2.0, rvm list known 列表里面的都可以拿来安装。

切换 Ruby 版本

rvm use 2.2.0

如果想设置为默认版本,这样一来以后新打开的控制台默认的 Ruby 就是这个版本

rvm use 2.2.0 --default 

查询已经安装的ruby

rvm list

卸载一个已安装版本

rvm remove 1.8.7
6) 更改gem source
$ gem sources --remove https://rubygems.org/
$ gem sources -a https://ruby.taobao.org/
$ gem sources -l
*** CURRENT SOURCES ***

https://ruby.taobao.org
# 请确保只有 ruby.taobao.org
然后就可以用gem了。
如果你使用 Gemfile 和 Bundle (例如:Rails 项目)
你可以用bundle的gem源代码镜像命令
$ bundle config mirror.https://rubygems.org https://ruby.taobao.org
这样你不用改你的 Gemfile 的 source。
source 'https://rubygems.org/'
gem 'rails', '4.1.0'
...
 

转自:
https://ruby-china.org/wiki/rvm-guide
http://stackoverflow.com/questions/4755538/rvm-is-not-working-in-zsh
http://ruby.taobao.org/

标签: Mac Ruby
来源:http://www.cnblogs.com/pinganzi/p/4689494.html

推荐: