ruby gem install rails 错误解决

作者: alovn
发布时间:2015-08-10 15:42:15

ruby gem install rails 错误解决 

错误信息:

ERROR: Error installing rails:
The 'atomic' native gem requires installed build tools.

Please update your PATH to include build tools or download the DevKit
from 'http://rubyinstaller.org/downloads' and follow the instructions
at 'http://github.com/oneclick/rubyinstaller/wiki/Development-Kit'

 

出错的原因是安装rails的时候,需要build tools,但系统中没有。出错信息中同时也给出了解决的法案:

1. 到http://rubyinstaller.org/downloads/ 去下载dev kit DevKit-xxx.exe

2. 按照http://github.com/oneclick/rubyinstaller/wiki/Development-Kit/ 安装dev kit

主要安装步骤如下:

1.如果原来系统中已经安装了旧版的dev kit, 则删除它

2.下载上面提到的dev kit

3.解压下载下来的文件到指定的目录,如c:/devkit。(注意:目录不能有空格)

4,在安装目录下运行ruby dk.rb,然后按照提示分别运行ruby dk.rbinit 和 rubydk.rb install来增强ruby

5,可以运行 gem install rdiscount–platform=ruby 来测试是否成功

按照安装步骤,完成了DevKit的安装。

然后,再次安装需要的gem即可.

标签: Rails Ruby
来源:http://www.cnblogs.com/alovn/p/3529765.html

推荐: