Ruby on Rails环境搭建及rubyMine安装

作者: 藏一颗桂圆
发布时间:2015-07-13 11:31:56

最近在学ruby,ruby是一种面向对象的编程语言,rails是Ruby的框架,就像java中的SSH一样。只是rails是MVC模式的。下面讲一下安装环境的过程。

安装Ruby on rails环境主要参考的是Ruby-china上面的教程贴,链接在此:https://ruby-china.org/wiki/install_ruby_guide

另外,最好在Linux内核上面使用,所以开始安装前请确保有一台linux内核的机器或者虚拟机或者双系统。

1.安装Ruby

现在的ruby版本应该是2.X了,建议不要装1.9版本的,因为2.0比1.9增添了许多新特性。下面都是在命令行中执行的

1.安装系统需要的包

ruby -e "$(curl -fsSL https://raw.github.com/mxcl/homebrew/go/install)"

2.装RVM。RVM就是Ruby运行的虚拟机,类似JVM一样的。

curl -L https://get.rvm.io | bash -s stable

然后,载入 RVM 环境(新开 Termal 就不用这么做了,会自动重新载入的)

 source ~/.rvm/scripts/rvm

检查一下是否安装正确

 rvm -v

如果安装正确的话,上一句输入之后在命令行应该能看见类似这样的回应:

rvm 1.22.17 (stable) by Wayne E. Seguin <wayneeseguin@gmail.com>, Michal Papis <mpapis@gmail.com> [https://rvm.io/]

重要的是rvm 1.22.17,这个就是你安装的Rvm的版本。

3用RVM安装Ruby环境

rvm install 2.0.0

这样Ruby,ruby gem都安装好了。Ruby gem是什么呢,它是个ruby的工具,用来管理各种库包。

4设置 Ruby 版本

RVM 装好以后,需要执行下面的命令将指定版本的 Ruby 设置为系统默认版本

rvm 2.0.0 --default

同样,也可以用其他版本号,前提是你有用 rvm install 安装过那个版本

这个时候你可以测试是否正确

$ ruby -v

ruby 2.0.0p247 (2013-06-27 revision 41674) [x86_64-darwin13.0.0]

$ gem -v

2.1.6

$ gem source -r https://rubygems.org/ (这句是把gem的默认下载源取消掉,改成taobao的源。因为国外的网站有时候可能连接不是那么稳定)

$ gem source -a https://ruby.taobao.org

2.装Rails

上面 3 个步骤过后,Ruby 环境就安装好了,接下来安装 Rails

$ gem install rails

然后测试安装是否正确

$ rails -v

Rails 3.2.13

如果安装过程中提示你缺少XX包,就按照命令行的提示执行gem install XXX就可以了。

附:如果你确定你安装好了ruby,rvm,rails,但是ruby -v,rails -v都看不到版本号的话,可以先在命令行中输入/bin/bash --login,然后再ruby -v试试

3.装rubymine

rubyMine是开发ruby的IDE,如果你喜欢在文本编辑器里写代码的话就略过下面的吧。

首先去官网下载,链接就不给了,百度之吧。

然后,注意这个软件是收费的,所以去搞个注册码神马的吧,百度一堆,按顺序试试就好了。

安装RubyMine要先安装jdk环境,这个写Java的都装过,略过不写了~

然后,要写项目的话呢,需要先bundle install一下,这个的意思就是按照你这个项目的配置文件中写的,绑定一下你需要的各种库文件。具体方法就是tools——bundler——install。可能会Bundle失败,提示你在bundle之前请确保XX包已经安装了,这是因为你并没有安装某个配置文件中写的包或者是相关的依赖包,按照提示的在命令行执行gem install XX(这里的XX是指包名)就好了。

来源:http://www.cnblogs.com/cangyikeguiyuan/p/4472607.html

推荐: