ruby on rails安装(ubuntu 14.04)

作者: Sophiawow
发布时间:2015-07-13 11:31:55

安装完windows版的,有人说新手千万不要用windows版的,因为会出现莫名其妙的错误,而且解决问题的方法很少,恩,最近小小的使用了下,还没有什么windows特有不能解决的问题,大概是才刚刚开始。项目用的服务器是ubuntu,所以嘛,还得用Linux不是,下面是ubuntu14.04麒麟下的安装方法,使用的是RVM安装,相对简单。
ubuntu 14.04 安装
1. 安装依赖:
    安装之前要使用sudo apt-get update更新一下源,否则可能会出现libcurl4-openssl-dev等缺少依赖的错误,在下面所有的过程中使用apt-get安装出现找不到安装包或依赖的错误,都首先update更新一下源,这里有ubuntu 14.04 source.list源
sudo apt-get update sudo apt-get install git-core curl zlib1g-dev build-essential libssl-dev libreadline-dev libyaml-dev libsqlite3-dev sqlite3 libxml2-dev libxslt1-dev libcurl4-openssl-dev python-software-properties
安装完成后,开始使用rvm安装ruby。
2. 使用RVM安装ruby  
其中RVM是Ruby Version Manager的缩写,即ruby版本管理器。可以自动查找并安装所需版本的ruby,并对ruby版本进行管理。
安装方法如下: 这里我们使用推荐的ruby-2.1.3
      a)安装依赖:
  sudo apt-get install libgdbm-dev libncurses5-dev automake libtool bison libffi-dev
      b)下载rvm:
  curl -L https://get.rvm.io | bash -s stable(这句话的解释)
Note
在执行该语句时,可能出现GPG signature verification failed for '/home/sophia/.rvm/archives/rvm-1.26.4.tgz'的错误,以为是权限的原因前面加sudo,结果在ubuntu麒麟14.04一次性通过,在ubuntu14.04中还是出现上述错误,然后又apt-get update了一下,再试安装成功。。。感觉跟网络思密达的有关呀。
安装成功~

c)载入RVM环境:
  source ~/.rvm/scripts/rvm
d)加入Shell(以后就无需每次执行上一步了)
  echo "source ~/.rvm/scripts/rvm" >> ~/.bashrc
e)安装ruby-2.1.3
  rvm install 2.1.3
   
f)将2.1.3设为默认版本
  rvm use 2.1.3 --default
g)测试:
  ruby -v
  显示为ruby 2.1.3p242 (2014-09-19 revision 47630) [x86_64-linux],安装成功~
h)添加设置:
  告诉rubygems不要为每个本地包都安装文档
  echo "gem: --no-ri --no-rdoc" > ~/.gemrc
3.安装rails:
首先在安装rails之前需要安装javascript runtime,如果不安装的话会出现rails sever时出错(请参考链接的错误4 ExecJS::RuntimeUnavailable),安装方法如下:
sudo add-apt-repository ppa:chris-lea/node.js
sudo apt-get update
sudo apt-get install nodejs
然后安装rails:
gem install rails
Note: 
有可能会出现错误The program 'gem' can be found in the follwing packages(在ubuntu麒麟上没有该错误)
最后rails -v测试成功~~~
4.使用rails:
与windows中相同rails new blog,cd到该目录下,使用rails s启动,http://localhost:3000测试一下。
oh~myladygaga~~就这样的成功了~~妈妈再也不用担心我的学习了~~  
 


来源:http://www.cnblogs.com/Sophiawow/p/4522475.html

推荐: