mac下升级ruby(已验证)

作者: 糊涂虫的爬坡
发布时间:2015-07-13 11:31:43

在lion下安装rails会提示你的ruby版本为1.8.7,而新版本的rails3.x需要1.9.x的ruby支持。

所以,必须对ruby进行升级,经过各种凌乱和不成功终于摸索出经验。现在记录一下。
  1. 通过app store安装xcode
  2. xcode安装好后,打开xcode
  3. 选择preferences
  4. 选择downloads选项卡
  5. 安装command line tools(因为终端里没有gcc的编译环境)
  6. 打开终端输入下面两条命令(安装rvm,ruby多版本控制器,通过rvm安装最新版本的ruby)
  7. curl -L get.rvm.io | bash -s stable
  8. rvm install ruby 1.9.3

来源: http://blog.sina.com.cn/s/blog_671ada97010113cb.html

标签: Mac Ruby
来源:http://www.cnblogs.com/tony_cap/p/3805448.html

推荐: