Mac上更新Ruby

作者: 无名盗闪
发布时间:2015-07-13 11:31:29

因为准备在项目中使用bootstrap,在安装bootstrap过程中提示需要Ruby的版本在1.9.2以上,而目前使用的Ruby版本是Mac系统自带的1.8.7。所以需要对Ruby进行升级。这里使用RVM对Ruby进行升级,升级过程如下:

1、安装 RVM

RVM:Ruby Version Manager,Ruby版本管理器,包括Ruby的版本管理和Gem库管理(gemset)

 

  1. $ curl -L get.rvm.io | bash -s stable  

等待一段时间后就可以成功安装好 RVM。

 

  1. $ source ~/.bashrc  
  2. $ source ~/.bash_profile  

测试是否安装正常

 

  1. rvm -v  

2、用RVM升级Ruby

 

  1. #查看当前ruby版本  
  2. $ ruby -v  
  3. ruby 1.8.7  
  4. #列出已知的ruby版本  
  5. $ rvm list known  
  6. #安装ruby 1.9.3  
  7. $ rvm install 1.9.3  

安装完成之后ruby -v查看是否安装成功。



标签: Mac Ruby
来源:http://www.cnblogs.com/waizi/articles/3583582.html

推荐: