centos安装ruby on rails

作者: 大智若简
发布时间:2015-07-13 11:31:04

  最近研究svn使用http协议,但网上大多都是Apache整合svn,我不想使用apache+svn,google翻了很多页终于让我找到了,但要求先安装ruby on rails,所以就有了下面的这篇文章.
   系统:centos 5.5
   需要的软件:ruby-1.9.3-rc1.tar.gz rubygems-1.8.23.tgz
1.安装ruby
wget http://ruby.taobao.org/mirrors/ruby/1.9/ruby-1.9.3-rc1.tar.gz
tar zxf ruby-1.9.3-rc1.tar.gz && cd ruby-1.9.3-rc1
./configure --prefix=/usr/local/ruby --enable-pthread
make && make install
然后给ruby加上环境变量
vi /etc/profile
PATH=$PATH:/usr/local/ruby/bin
export PATH
验证:
ruby -v 点击查看原图
可以看到ruby安装成功.
 
2.安装rubygems
wget http://files.rubyforge.vm.bytemark.co.uk/rubygems/rubygems-1.8.23.tgz
tar xf rubygems-1.8.23.tgz && cd rubygems-1.8.23
ruby setup.rb
如果出现下图,就可以开始安装rails on ruby
点击查看原图
3.安装rails on ruby
正常情况下,运行gem install rails --include-dependencies就可以自动安装了,当然前提是你的机器可以上网.
gem install rails --include-dependencies
如果出现file 'lib' not found的错误,那大家可以执行下面的命令就可以解决
gem install rdoc 点击查看原图
其实,这是针对发展过快的rails,默认编译的rdoc模块不能跟上步伐的原因.
然后再继续gem install rails就可以了.
 
4.验证ruby on rails安装
rails -v 点击查看原图
可以看到rails已经成功安装.

来源:http://www.cnblogs.com/zxktxj/p/3954360.html

推荐: