openSUSE13.2安装ruby和rails

作者: 一梦轻枫
发布时间:2015-07-13 11:30:36

用rvm安装了ruby2.2.0之后,发现rails又装不了了,因为什么nokgiri安不上
需要安装两个包:
  • libxml2
  • libxml2-dev
  • libxslt
  • libxslt-dev
然后
gem install nokogiri -- --use-system-libraries --with-xml2-include=/usr/include/libxml2 --with-xml2-lib=/usr/lib/
然后
gem install rails -V --no-ri --no-rdoc
就行了
然后发现还特么时不行:因为缺少js运行环境,所以运行rails s 都不行啊卧槽
见此帖子:https://ruby-china.org/topics/692
说是安装therubyracer也行,但是我按了还是不行你妹的!
我就安了node.js
zypper install nodejs
然后每次打开新的Shell还要登陆:
bash --login  

 

 

来源:http://www.cnblogs.com/hitnoah/p/4188650.html

推荐: