CentOS6 安装ruby on rails 环境

作者: V42
发布时间:2015-07-13 11:30:22

使用源码安装ruby. yum仓库的版本为1.8.7.rails要求的最低版本为1.9.2.

1.ruby官网下载 https://www.ruby-lang.org/

  版本为 Ruby 1.9.3.

2.解压并安装

tar -zxvf ruby-1.9.3.tar.gz  cd ruby-1.9.3  ./configure
make make test make install

  ruby -v出现版本信息说明安装成功.

3.gem更换成taobao的源.

gem sources --remove http://rubygems.org/  gem sources -a http://ruby.taobao.org/  gem sources -l  # 请确保只有 ruby.taobao.org

4.安装rails

gem install rails

如果有缺失的ruby包依赖运行budle install,安装所有的依赖包.

 
参考链接:
http://blog.163.com/pzy1991@yeah/blog/static/1220572312011112622419700/

  

来源:http://www.cnblogs.com/viator42/p/3564671.html

推荐: