ubuntu12.04 安装 ruby on rails

作者: 姜大伟
发布时间:2015-07-13 11:29:59

首先 ,用软件升级管理器,更新一下要更新的东西,(这一步不知道是不是必须的,反正小心无大错)

第一步执行 更新系统 
 sudo apt-get update

 sudo apt-get upgrade

sudo apt-get dist-upgrade

 

sudo apt-get install git

配置一下信息,可不做。

 git config --global user.name "Elson"  

 git config --global user.email "elson@**.com"  

 

Git 是一种免费的软件版本管理工具, 安装完成 Git 后需要进行设置 

 sudo apt-get install curl

安装开发包

$ sudo apt-get install wget vim build-essential openssl libreadline6  libreadline6-dev curl git-core zlib1g zlib1g-dev libssl-dev libyaml-dev  libxml2-dev libxslt-dev autoconf automake libtool imagemagick libpcre3-dev

安装ruby

$ sudo apt-get install ruby1.9.3  

安装完,测试下

$ ruby -v  ruby 1.9.3p0 (2011-10-30 revision 33570) [i686-Linux]  $ gem -v  1.8.11  

可以将gem源换成taobao 的源

$ gem source -r http://rubygems.org/  $ gem source -a http://ruby.taobao.org  

安装rails 环境

$ gem install bundler rails  

测试下

$ bundle -v  Bundler version 1.1.3  $ rails -v  Rails 3.2.3  

其它

安装sqlite3 及相关依赖

$ sudo apt-get install sqlite3 libsqlite3-dev  

安装nodejs,npm

$ sudo apt-get install nodejs npm  

安装mysql 相关 (用的上再装吧)

$ sudo apt-get install libmysql-ruby libmysqlclient-dev

 

来源:http://www.cnblogs.com/davytitan/archive/2012/09/27/2706014.

推荐: