搭建ruby on rails(3.1)之安装gem mysql2

作者: eric_chen
发布时间:2015-07-13 11:29:43

直接借助现有的ide都会帮我们搭建出一个rail项目代码框架。

但在运行的时候,就出现了mysql2版本对不上的问题。找了网上很多资料,很多都是说下载mysql connector,然后通过如下命令安装mysql2的gem:

gem install mysql2 -- '-with-mysql-lib="E:\opensource\6_database\mysql\mysql-connector-c-noinstall-6.0.2-win32" -with-mysql-include="E:\opensource\6_database\mysql\mysql-connector-c-noinstall-6.0.2-win32\include"'

以上命令中注意几个地方:

1.mysql2后面的"--"后面还有个空格

2.整个命令最后还有个'.

3.各位在安装时,根据自己环境里面的对应路径。

4.特别指出:mysql-connector-c-noinstall-6.0.2-win32是32位系统里面的。我的电脑是64位,以为应该下个64位的connector,一直安装不成功。后来发现gem list里面的

   mysql2是mysql2 (0.3.11 x86-mingw32),才想到应该换成32位的。。

5.以上这些都做了,如果还是不行,那就把mysql-connector-c-noinstall-6.0.2-win32中lib下的文件拷贝到Ruby192\bin下。

6.再做补充,如果你的ide还是提示版本对不上,请重启ide。

7.对于gem安装mysql2,有些可能会出现需要dev bundle的提示。这个可以到网上遍历,有很多这方面的说明。

来源:http://www.cnblogs.com/ericchen/archive/2011/12/29/2305977.h

推荐: