ruby 1.9.2p290+rails2.3.4+mysql5.5.15 数据库访问不了

作者: 相思雨
发布时间:2015-07-13 11:28:32

我的环境是 ruby 1.9.2p290+rails2.3.4+mysql5.5.15 ,运行“db:migrate”时,错误提示如下 :
!!! The bundled mysql.rb driver has been removed from Rails 2.2. Please install the mysql gem and try again: gem install mysql.
rake aborted!
RubyGem version error: mysql(2.7.3 not >= 0)
(See full trace by running task with --trace)
这是什么原因造成的? 按照提示 运行 “gem install mysql”提示 “ERROR:  Could not find a valid gem 'mysql' (>= 0) in any repository”

 

解决方案:

1、到http://www.tmtm.org/en/ruby/mysql/下载并安装ruby-mysql

Install
# ruby ./install.rb(今天又验证了一下,这个第一步是针对Linux下面的解决方案,千万不能执行,否则连接数据库的时候会遇到问题,数据库的安装就按照http://www.cnblogs.com/huzhiwei/archive/2012/02/22/2363721.html来进行就可以)  
2、到http://rubyforge.iasi.roedu.net/gems/下载mysql-2.7.3-mswin32.gem

gem install mysql-2.8.1-x86-mswin32.gem


3、将mysql的bin目录下的libmySQL.dll拷贝到ruby的bin目录下(这个貌似不是必须的,可以参看http://www.cnblogs.com/huzhiwei/archive/2012/02/27/2369423.html对limSQL.dll的处理)
 

来源:http://www.cnblogs.com/huzhiwei/archive/2012/02/22/2363861.h

推荐: