Mac OS X 10.4.8 下安装Ruby On Rails

作者: Tachikoma
发布时间:2015-07-13 11:26:49

原来在Windows下都用 Ruby One-Click安装Ruby,然后利用Ruby-gem,安装Rails,ZenTest等等

这次千辛万苦换到Mac,还是免不了一顿麻烦

首先,推荐一篇文献

http://wiki.rubyonrails.org/rails/pages/Installation
其实一步步来一点问题都没有,但是...

1] 这时候才发现自己的MAC OS X没有XCode,安装盘很显然为了压缩也删掉了这一块,除了苹果网站外其他没有提供下载的,而苹果网站下载Developer Tools需要Apple ID,...
作为一个要学习的人,还是有时候要用点不法手段的,Following the solution
http://www.tctcclub.com/milo/article.asp?id=252
用的方法大致相同,稍有区别,不便明说

2] 对比文献提供的方法,还是BIBLE上提供的一些方法,还是相对喜欢包管理器安装的模式[秉承我一贯怕麻烦的传统],刚从WINDOWS迁移过来,虽然以前用过一段fedora,但是还是不太习惯,故选择了MacPorts
但是...MacPorts的One-Click安装在运行安装脚本时无限制停滞,没找到原因,可能是MACOSX破解的问题,又不想自己手动编译,另找出路

3] 对于 Locomotive 一次安装一大堆的模式,从心底里觉得,诶...
4] Ruby One-Click Installer ,好东西,安装必要的东西,Ruby,Ruby-gems,Mongrel,SQLite,没什么多余的东西,剩下不用我说了
5] Ruby-gems安装回来需要升级一下才能下载rails
sudo gem update --system
6] End
7] 如果你真得能坚持看到这里,而且没开始下载庞大的XCode,那么恭喜你,因为在文献里有这样一句话闪烁光芒
This package is only 13MB, so you may find it useful if you would rather not download the Apple Developer Tools (Xcode) at around 900MB.
如果你真得看懂的话...amen
有个值得高兴的消息,对于那些仍然看到了这里并且在后悔或者在关闭下载程序的人,那就是:我也没看到这句话

来源:http://www.cnblogs.com/Tachikoma/archive/2008/02/27/1083999.

推荐: