教你安装RVM,ruby,rails(非windows)...

作者: kelby
发布时间:2015-07-13 11:26:48

对于新手来说,安装rails有时确实是一件痛苦的事。这也不懂,那也不懂。尽管网上这教程一搜一大把,但如何‘选择’又是另一个大问题了。
网上教你如何安装rails的教程可以说数不胜数,这也只是其中这一,作者希望能够对你有帮助~~~
首先说明,这教程不适用于Windows,作者本人也只是在ubuntu上安装成功,其它的类Linux应该‘大同小异’吧。
第一步,打开终端Ctrl+T。
然后升级一下源,执行:
sudo apt-get update
接下来,我们安装Git (一个版本控制系统)和curl, RVM的安装和使用需要使用到它们,还有build-essential用来编译 Ruby。为了安装这三个包,我们执行:
sudo apt-get install build-essential git-core curl
这就可以安装RVM了,执行(这命令是一行):
bash < <(curl -s https://raw.github.com/wayneeseguin/rvm/master/binscripts/rvm-installer )

执行后,注意看一下终端上显示的内容,你安装RVM,需要依赖一些包!!
可用apt-get或aptitude安装,例如执行:
sudo apt-get install build-essential bison openssl libreadline6 libreadline6-dev curl git-core zlib1g
zlib1g-dev libssl-dev libyaml-dev libsqlite3-0 libsqlite3-dev sqlite3 libxml2-dev libxslt-dev autoconf


然后执行(这也是一行):
bash < <(curl -sk https://raw.github.com/wayneeseguin/rvm/master/binscripts/rvm-installer)
为了加载rvm,执行(一行):
echo '[[ -s "$HOME/.rvm/scripts/rvm" ]] && . "$HOME/.rvm/scripts/rvm" # Load RVM function' >> ~/.bash_profile
好了没有?关掉终端重新打开,执行:
source .bash_profile
(什么也没显示,就对了)
再执行:
type rvm | head -1
(显示rvm is a function ,就对了)

想安装ruby吗?(废话)
执行:
rvm install 1.9.2
(时间看你网速了,可能很久)
使用ruby 1.9.2
执行:
rvm use 1.9.2
查看一下版本和运用在哪的。
user$ ruby -v
ruby 1.9.2p180 (2011-02-18 revision 30909) [i386-darwin9.8.0]

user$ which ruby
Using /Users/user/.rvm/gems/ruby-1.9.2-p180/bin/ruby


最后,让ruby 1.9.2为默认(ruby)版本,执行:
rvm use 1.9.2 --default

ok,到此结束。。。
(哦,,,还没安装rails呢?!)
执行:
gem install rails

提示:安装rails,时间可能很久,看你网速了。如果提示找不到源或者错误的,你需要挂上VPN(翻#墙),或者第二天再安装Rails
也就是执行:
gem install rails
(为什么第二天就能安装好了?这原因我也不知道。)

其它的gem,可以执行:gem install XXX
来安装。

请参考:https://rvm.beginrescueend.com/rvm/install/

(如果还有不懂,可以加我qq1403126229 ,ruby & rails我和你一起学习)

转载请注明出处www.cnblogs.com/kelby  谢谢。

标签: Rails Ruby Windows
来源:http://www.cnblogs.com/kelby/archive/2011/10/24/2223112.html

推荐: