[脚本_Ruby]Windows安装配置Ruby On Rails

作者: It's_Lee
发布时间:2015-07-13 11:25:56

感觉Java学的差不多了,想接触下Ruby On Rails,看看它比Java WEB高效到哪里了,在Ubuntu12.10上弄了两天总是报错提示没有指向的文件sqlite3,不管怎么安装sqlite3都不行,到最后没办法只有跑到WIN7平台下试试,以下就是我搭建Ruby On Rails的过程:

       首先也是需要下载ruby,在Windows下有直接安装的exe文件,可以从rubyinstaller下载到自己需要的ruby版本,我下载是rubyinstaller-2.0.0-p247,我看有的教程还说需要安装gem,我发现通过rubyinstaller-2.0.0-p247安装之后直接就有gem了,所以安装gem这一步也就省略了。安装之后你可以打开Start Command Prompt with Ruby命令窗口,查看版本号:ruby -v和gem -v

      我是不明白,天朝为啥把那么多的技术网站都给墙了,淘宝给我们提供了一个镜像http://ruby.taobao.org可供我们使用,所以在通过gem install rails 之前我们需要把镜像源从国外改到淘宝提供的上去。可借助下列命令:

 

  1. gem sources -a http://ruby.taobao.org/  

可以通过下列命令查看所以镜像源:

 

  1. gem sources -l  

同时也可以删除镜像源:

 

gem sources --remove https://rubygems.org/

自我感觉把这些国外被墙的镜像源去掉会节约时间,我是把所以国外的都去掉就剩下淘宝的镜像源。这个时候就可以开始安装Rails了:

 

  1. gem install rails -V  

当我这安装到最后的时候出现了一个错误:意思就是缺少DevKit,这个时候还需要Devkit下载个DevKit。下载之后你可以解压到指定的目录中,如我的:D:/devkit。之后进入到这个目录,执行ruby dk.rb然后根据提示执行ruby dk.rb init和ruby dk.rb install。等待安装成功!

ruby dk.rb install

---

Invalid configuration or no Rubies listed. Please fix 'config.yml'
and rerun 'ruby dk.rb install'
如果出现的是这个,则需要修改config.yml

加入

- C:\Ruby200-x64

 =================

可能报错,显示ruby的版本过低,rails需要>=1.9.2版本的ruby,可以通过手动下载安装即可。

Linux系统的ruby安装 

ruby安装包 
下载地址:http://www.ruby-lang.org/en/downloads/ 
ruby-1.8.6-p111.tar.gz 
解压并安装: 
tar -xvzf ruby-1.8.6-p111.tar.gz 
cd ruby-1.8.6-p111 
./configure  -prefix=/opt/modules/ruby 
make 
make install 
操作系统PATH路径: 
export PATH=/opt/modules/ruby/bin:$PATH 

=================

有的说可以通过:

 

  1. gem install rdiscount --platform=ruby  

测试是否成功,但是我测试的时候好像提示有什么问题,我也没有管它,接着安装rails就成功了!

测是rails -v 我的版本是4.0.0

之后就开始建立一个hello项目试试手啦!

 

==================

推荐:

不采用cygwin,而采用官方exe,zip等文件手动安装ruby,gem,rails等:

本文详细介绍如何在Windows配置Ruby on Rails 开发环境,希望对ROR初学者能有帮助。

一、下载并安装Ruby

Windows下安装Ruby最好选择 RubyInstaller(一键安装包)。
下载地址: http://rubyforge.org/frs/?group_id=167 。
我们这里下载目前较新的rubyinstaller-1.9.3-p0.exe 一键安装包。这个安装包除了包含ruby本身,还有许多有用的扩展(比如gems)和 帮助文档。

双击安装,安装过程出现如下界面。如图

这里我们选择安装路径为 D:\Ruby。 下面有3个选项分别是:(1) 是否安装tclTk支持。(2) 添加ruby命令路径到系统环境变量PATH。(3)是否将 .rb 和.rbw 文件关联到Ruby。
这里我们全部打勾。点击“Install” 安装完毕。

打开CMD窗口,运行 ruby -v 显示ruby当前版本号。如图

你也可以输入 ruby -e 'puts "hello world" ',则显示 hello world。

也可以打开记事本写一段代码如: puts "hello world",保存为 test.rb,然后在CMD中 运行 ruby test.rb 则显示结果 hello world。

我想你不甘心就用记事本来写程序吧,这里推荐一款轻巧的代码编辑器SciTE,支持多种语法高亮显示及高亮导出,且免费开源。以前的RubyInstaller 自带SciTE,而新版需要自己下载。官方地址:scintilla.org windows下有绿色版和安装版,安装版下载 点这里

安装SciTE后,打开它,我们输入代码 puts "hello world" ,点击菜单=>file=>save 保存文件为test.rb。 然后按键盘F5,右侧输出窗口出现结果。如图:

二、下载并安装RubyGems

RubyGems是一个方便而强大的Ruby程序包管理器,类似RedHat的RPM。它将一个Ruby应用程序打包到一个gem里,作为一个安装单元。 特点:能远程安装包,包之间依赖关系的管理,简单可靠的卸载,查询机制,能查询本地和远程服务器的包信息,能保持一个包的不同版本,基于Web的查看接口,能查看你安装的gem的信息。

从官方下载RubyGems,以zip版本为例,解开压缩包,从CMD提示窗口下进入setup.rb所在目录, 运行 ruby setup.rb 即可安装。

较新的Ruby版本已经包含RubyGems了,因此我们不用手动下载安装了。只需在CMD窗口输入指令:gem update --system ,耐心等待一段时间,已有的RubyGems会更新到目前最新的版本。如图。

三、下载并安装Rails

从CMD提示窗口输入指令:gem install rails 开始安装rails。

如不想安装文档文件,可以输入:gem install rails --no-rdoc --no-ri 

程序自动下载并安装rails, 耐心等待。如图所示:

安装完成后,你可以在路径 D:\Ruby\lib\ruby\gems\1.9.1\gems 看到些东西,都是rails的包文件,与ruby安装在同一目录下。

这时在CMD提示窗口输入指令: rails -v  显示rails的版本号。如图:

四、下载并安装DevKit

DevKit 是windows平台下编译和使用本地C/C++扩展包的工具。它就是用来模拟Linux平台下的make, gcc, sh来进行编译。这个方法目前仅支持通过RubyInstaller安装的Ruby。

下载Devkit:http://rubyinstaller.org/downloads

如果上面的地址打不开,就从这里下载:https://github.com/oneclick/rubyinstaller/downloads/

我们这里使用目前较新的版本 DevKit-tdm-32-4.5.2-20111229-1559-sfx.exe

安装步骤:

1) 将下载 DevKit 解压到 D:\DevKit 目录。
2) 打开 CMD 窗口,进入 D:\DevKit 目录,输入ruby dk.rb init 。#生成config.yml,这里会检查将要添加DevKit支持的Ruby列表,只支持通过RubyInstaller安装的Ruby。
3) 输入 ruby dk.rb install  #开始安装。
4) 输入 ruby dk.rb review  #检查要添加DevKit支持的Ruby列表是否有误,可以略过。
5) 输入 gem install rdiscount --platform=ruby 。#这一步只是验证DevKit是否安装成功,如果能安装rdiscount成功说明安装DevKit成功,也可以不做。


整个过程如图:

 

五、创建一个Rails项目

打开CMD提示窗口,进入D盘,输入指令:rails new www ,会在D盘创建名称为www 的rails项目结构。

接着进入www目录,输入指令:rails server ,启动rails自带的 webrick 服务器。如图:

 打开浏览器输入地址 http://localhost:3000/ 看到欢迎页面,如下图:

下来我们让Rails说 "Hello"

Rails是一个MVC框架,Rails接收来自浏览器的请求,对请求进行解读以找到合适的控制器,再调用控制器中合适的方法。然后,控制调用合适的视图,把结果显示给用户。Rails提供了快速创建视图和控制的方法,打开CMD命令窗口。进入到刚才的www项目目录,输入命令:rails generate controller say hello 如图:

 

下面我打开上图中提示的视图文件,路径是 /项目目录/app/views/say/hello.html.erb

修改为如下形式:

    <h1>Say#hello</h1>       <p>现在时间是:<%=@time%></p>   

注意:将视图文件 hello.html.erb 另存为UTF-8编码格式,否则中文会出现乱码。说明一下是UTF-8编码,而不是 UTF-8 +BOM 编码,BOM 是通过文件开头添加几个字符表示文件编码的标准。但是只有微软用了,x-nix 、PHP、Ruby 不认。

接着打开控制器文件,路径是 /项目目录/app/controllers/say_controller.rb

修改为

  class SayController < ApplicationController       def hello          @time=Time.now        end      end  

打开浏览器访问:http://localhost:3000/say/hello,结果如下图。

如果要更改首页,让首页显示Hello。只需2步:

1) 找到 /项目目录/config/route.rb 文件,查找到这行  # root :to => 'welcome#index'  去掉注释并设置为自己的控制器,修改为 :

     root :to => 'say#hello'

2) 删除 /项目目录/public/index.html 文件,因为rails优先读取public目录下的静态文件。

再次访问:http://localhost:3000,首页显示Say#Hello,于上图的内容一致。

六 创建一个使用MySQL数据库的Rails项目

1) 打开CMD窗口,进入D盘,输入命令:rails new work --database Mysql,在D盘创建名称为 work 的rails 项目结构。

2) 必须将libmysql.dll库拷贝到 Ruby安装目录的Bin目录下(D:\Ruby\Bin)。否则在启动服务器时候会提示:“没有找到LIBMYSQL.dll,因此这个应用程序未能启动。重新安装应用程序可能会修复此问题。”

    下载地址:http://www.mysql.com/downloads/connector/c/

    我们这里下载 mysql-connector-c-noinstall-6.0.2-win32.zip ,解压缩,在lib目录里面的libmysql.dll 就是我们要找的。

3) 修改数据库的配置信息。在 /项目目录/config/database.yml 文件中,分别对应 “开发”、“测试”,“生产” 数据库的配置,把他们修改为自己的配置。

    其中development是我们开发中要实际使用的数据库。一定要注意在username: 和 password: 后面至少要保留一个空格。

4) 在CMD窗口输入rake db:craete  命令,会在msyql 中创建由配置信息中所设置的数据库。

5) 我们用scaffold来生成代码,在CMD中输入下面指令:

    rails generate scaffold post title:string body:string addTime:datetime

    这时候会创建controller, views, models和数据库脚本,但此时还没有创建表。

    再输入:rake db:migrate 创建表。完成。

6) 执行命令 rails server

    通过浏览器访问:http://localhost:3000/posts 这个页面已经为我们生成了增删改查代码,OK。

 =====================

 

原文链接:http://www.hcrazy.com/?p=25
在windows平台下开发rails应用程序,可以按照以下方式搭建开发环境,让你以最快的速度领略到ruby on rails的神奇。

首先需要准备以下内容

1、windows下的ruby安装包,本人使用ruby1.9.2版本,下载地址:

http://rubyinstaller.org/downloads/ 选择Ruby 1.9.2-p290

2、ruby打包工具:RubyGems. 我们可以通过该工具下载rails及其所需的各种组件。经测试,安装完上面的ruby程序(我下载后的安装包全名为:rubyinstaller-1.9.2-p290.exe),BubyGems已经集成在里面了,后面介绍如何查看。

3、rails 框架。rails是用ruby编写的web开发框架,要开发rails应用程序,必然要下载rails了,这个就可以使用上面所说的RubyGems来轻松安装了

4、数据库。rails支持各种数据库,最简单的方式就是使用嵌入式的sqlite3数据库,这里就以sqlite3为例,下载地址:

http://www.sqlite.org/download.html 选择Precompiled Binaries for Windows

然后下载前两个:sqlite-Shell-win32-x86-3071502.zip、sqlite-dll-win32-x86-3071502.zip ,后面介绍如何使用,先将下载后的压缩包放到任意目录下即可。

5、安装DevKit。DevKit 是windows平台下编译和使用本地C/C++扩展包的工具。它就是用来模拟Linux平台下的make, gcc, sh来进行编译。

ok,准备工作完成,下面开始安装rubyinstaller-1.9.2-p290.exe

安装过程非常简单,需要注意的就是选中如图所示的后两项,这样就自动将ruby设置到windows的环境变量里去了,省了你再设置环境变量的功夫了,一步到位,安装顺利完成。

接下来,就是运行cmd.exe了,输入ruby -v检测ruby的安装版本,如下图所示:

如果显示出你的ruby的安装版本了,就表示你安装成功了。接下来,继续输入gem -v

就像前面我提到的,RubyGem默认集成到rubyinstaller安装包里的,我这里显示的是gem版本为1.7.2。

好了,再往后就是安装rails及相关依赖组件了,命令行输入:gem install rails

我在公司的电脑里安装时,没有遇到问题,直接跳到下一步(后面介绍)。但是,在我家里电脑安装时,则遇到如下问题:

经过不断的在网上搜索,分析,最终goooge到了我要的答案,原因就是网络原因,家里的网速太慢(4M),导致连接 rubygems.org失败,因此会出现上面的错误,幸运的是,淘宝网提供了镜像服务,只要按照下面的几个步骤后,就可以正常安装rails了。

1、打开http://ruby.taobao.org/

2、按照网站上的说明,依次输入下面的命令:

gem sources --remove https://rubygems.org/
gem sources -a http://ruby.taobao.org/
gem sources -l

最后得到结果

*** CURRENT SOURCES ***

http://ruby.taobao.org

不过,我在执行上面步骤时,有些不一样,执行gem sources -l 后,结果如下:

需再次执行gem sources --remove http://rubygems.org/http不是https。然后再执行,注意,这次按照上面列表上显示的是

gem install rails 就ok了。

rails安装成功了吗?呵呵,还没有,上面那个截图只是一部分,还有下面一部分,显示的是错误:

ok,这个错误也很明显,就是安装json的组件包时出现了问题,需要使用DevKit工具才能安装。这个工具在开始的准备工作里第5条中略微提了下,这里提供下载链接:http://rubyinstaller.org/downloads/

然后,滚动条使劲往下拉,可以看到 Development Kit 黑体部分,选择DevKit-tdm-32-4.5.2-20111229-1559-sfx.exe进行下载即可。下载后解压到一个目录,我的是: D:\Ruby\DevKit。然后命令行切换到D:\Ruby\DevKit目录,依次执行以下命令

ruby dk.rb init

ruby dk.rb review

ruby dk.rb install

如下图所示:

然后再运行一遍:gem install rails,此时就会真的成功了!恭喜恭喜!还剩下最后一个部分,就是安装sqlite3数据库。

将本文开始部分准备的关于sqlite3的两个压缩包解压缩,得到3个文件,复制到ruby的安装子目录bin下,我这里是:D:\Ruby\Ruby192\bin。然后命令行输入:gem install sqlite3

到这里安装工作总算完成了,下面就来创建一个简单的应用爽爽吧。

首先创建一个你自己的工作目录,我的是:D:\Ruby\works,然后进入cd D:\Ruby\works,命令行输入:rails new demo

此时,rails会在你的works目录下创建一个demo项目,demo文件夹里默认安装了一系列文件,暂时先不用理会他们,等我下次在给大家详细介绍,呵呵。

当然,在这里,我也遇到了一个问题(其实,如果网络够好的话,没有这么复杂,这么多问题,问题就在于我们天朝的网络了!!!),就是在运行rails new demo 期间,卡在run bundle install这里了。

解决办法:重新执行命令:rails new demo --skip-bundle,进入到demo目录下,然后再次运行bundle install ,哈,失败!但是,至少出现内容了:

连接不上https://rubygems.orghttps的原因,好说,进入到demo目录,找到Gemfile文件,打开,将第一行:source,看来是 'https://rubygems.org' 修改为:source 'http://rubygems.org',这里就不截图了,呵呵。

再次进入到demo目录,运行bundle install,怎么样?成功了否?还是不行?好家伙,好吧,还记得前面提到的淘宝镜像吗,替换成它,这网速总该可以了吧,继续修改Gemfile文件,将第一行source 'http://rubygems.org' 再改为

source 'http://ruby.taobao.org/'

运行bundle install ,闭上眼睛,20秒后睁开,哇。。。这次是真的ok了,呵呵,有图有真相:

Complete!,还有耐心吗?呵呵,只要你再输入最后一个命令,你就可以通过浏览器运行你的app了。

demo目录下命令行输入:rails server ,上图:

看到了吗?你的rails应用程序服务器启动成功了,赶快打开浏览器体验一下吧:

输入:http://localhost:3000 最后一张图:

关于rails的开发环境在windows下的搭建过程就简单介绍到这里,欢迎大家继续关注,我会持续学习,持续更新的!

来源:http://www.cnblogs.com/webapplee/p/4016410.html

推荐: