Eclipse新建Android项目时,出现appcompat_v7工程错误和红色感叹号(提示一堆style错误)

作者: MyronChi
发布时间:2015-07-13 10:41:45

发现问题

在Eclipse中创建Android项目:
1.首先我安装好了JDK,并且eclipse也是最新版的eclipse-luna64位版
JDK安装正确

2.然后我也安装并配置好了Android的SDK
3.我下载了最新版的eclipse的ADT插件,版本号为23.0.4(android.com上的最新版)
4.然后当我新建项目之后,出现如下所示错误提示,并在创建完项目之后,项目列表中自动新建appcompat_v7依赖包,但是继续创建项目的话,appcompat_v7工程也仅有一个:
项目错误提示


解决方法

分析

各种百度得知,appcompat_v7是Google的一个兼容包,就是一个支持库,项目新建后之所以会生成appcomat_v7工程,是为了能兼容2.2以上的版本,eclipse在新建项目的时候自动关联了所需要的lib,关联方式可通过 [项目 -> Properies -> Android ->Libary] 进行查看。
如果不想让appcompat_v7自动生成,可以在创建项目时,将Minimum Required SDK(即兼容的最小版本)设置为4.0,那就不会有这个工程的出现了;
但是,我们还是需要解决这个问题的。

解决方法(我们从头来过)


一、新建工程的情况

1.下载SDK及Support Library支持库
打开Android SDK Manager,把最新的Android SDK和Tools里对应的Android SDK Build-tools下载下来,并下载Extras下的Android Support Respository,Android Support Library

2.将新建工程的“主工程”和“appcompat_v7依赖包”的Android版本都改成与依赖包版本相同,当前我的情况下只需将“主工程”的Android版本改成Android 5.0.1
这里写图片描述

3.之后clean下Project重新编译下就能发现错误消失了


二、导入工程时,也会出现上述错误

(由于不是新建项目,Android不会自动生成appcompat_v7包,但是错误仍然错在的解决方法):
1.找到Android SDK目录下的sdk\extras\android\support\v7\appcompat,必须将该appcompat拷贝到目前的Java WorkSpace目录下

2.之后,将该appcompat导入到Eclipse中

3.并将主工程项目也拷贝到Java WorkSpace目录下,再在Eclipse中导入该主工程项目
(此处的2个项目,必须同时都位于WorkSpace目录下,否则第4步的添加项目依赖将会失败)

4.为该工程项目添加appcompat项目依赖

5.不出意外,Android自动编译后,错误提示将消失。

版权声明:本文为博主原创文章,未经博主允许不得转载。

来源:http://blog.csdn.net/MyronChi/article/details/46400411

推荐: