GitHub上项目配置和导入eclispe的问题解决

作者: 爱生活,爱编程
发布时间:2015-07-07 16:16:25

      在github上下载的工程文件导入的时候总是遇到各种各样的问题,昨天晚上瞎忙一晚上查资料没搞定。早上找高手请教了一下,一起弄了好一会终于解决了,这里记录一下方法解决的具体方法步骤。

      本方法适用于离线导入github工程,没有使用maven和egit工具。

测试项目以github上的一个下拉刷新的listview为例。

第一步:下载项目的zip压缩包解压到你的工作空间(其它地方也行只要能找到)


第二步:导入android工程:



选择你的要导入的项目:



点击Finish完成导入,工程目录展开如下:


第三步:设置编译环境

一般情况下,第二步结束后,看知道这么多错误就纠结了。这里有个3问题:

1.libraryproject是作为一个library为PullToRefreshListViewSampleActivity提供第三方库的支持,但是eclispe导入后默认没有把它设为库和PullToRefreshListViewSampleActivity关联起来,所以会看到PullToRefreshListViewSampleActivity的src中的java文件导入包报错。


2.PullToRefreshListViewSampleActivity和libraryproject两个工程的java文件中都会提示重写的函数错误需要删除函数开头的“@Override”。删除以后确实可以解决问题。但是根本原因是,java的jdk版本问题,我导入工程以后默认使用的事jdk1.5。要解决这个问题需要把jdk设置问1.6,1.6版本的JDK比较稳定,推荐使用。


3.还能够明显看到PullToRefreshListViewSampleActivity工程没有android的sdk库支持。需要手动设置编译环境。

下面就针对以上三个问题进行设置:

解决第一个问题,首先,设置libraryproject做为库支持



解决第二个问题,把libraryproject的java编译环境换为jdk1.6



PullToRefreshListViewSampleActivity进行设置,解决第二个问题,把PullToRefreshListViewSampleActivity的编译环境设为jdk1.6



解决第一个问题,选择PullToRefreshListViewSampleActivity所需的第三方支持库,这个选择必须在libraryproject设置为“is library”后才可以出现选择框。



解决第三个问题,选择(添加)PullToRefreshListViewSampleActivity的android sdk编译环境。我选的是Adroid  4.2。



所有的设置完成以后,工程项目的配置也就结束了。下面是设置完成后的项目列表。直接就可以正常运行了。


后记:

      配置完整个项目后,我想了一下为什么github上的想么要这么设置。为什么不是直接下载下来导入用就可以了呢?还需要这么麻烦的配置。我认为,这充分体现了开源项目的共享和兼容特征。一个项目的编译环境根据每个人的电脑设置可能会有所差别。比如,在不同的操作系统上开发的项目。mac,Linux,windows等平台上都可以搭建Android开发环境,但是难免会有一些系统依赖性。为了让项目能在不同的平台上都能正常的运行起来,那么就直接发布核心的代码,项目环境让开发人员自己搭建。这样依赖关系就大大降低了。这个人的一些理解。

标签: Git GitHub Lisp
来源:http://www.cnblogs.com/snake-hand/p/3141245.html

推荐: