使用github上面别人的pyqt4+pyserial代码的时遇到的问题

作者: 散吧散吧
发布时间:2015-07-07 16:12:45

因为想要学习python界面和串口通信。所以在github上面找到了这个一个程序 地址是http://eli.thegreenplace.net/2009/08/07/a-live-data-monitor-with-python-pyqt-and-pyserial 我使用git将代码clone出来之后在命令行下面运行对应的文件,出现如下的错误:

根据提示感觉是因为自己没有安装Qwt5引起的,所以去网上找Qwt5的安装包,在谷歌code上面看了下,说最新的代码迁移到了github上面去了,然后在github上面找到了Qwt5项目的代码:

没哟发现有exe的安装包,然后看到网上有人说使用 python setup.py install命令安装。于是我尝试了下:

看起来是装成功了,但是切换回我想要执行程序的那个目录继续执行我之前的程序还是提示

no module named Qwt5和之前的错误一样,我就怀疑是在Qwt5的安装哪里不对,但是我是新手,所以请大家帮我看看,是哪里出了什么问题?

标签: Git GitHub QT RIA
来源:http://www.cnblogs.com/51mcu/p/4338498.html

推荐: